MyApps Service Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 13:12 EDT

Identified

OIT is aware of an issue affecting myapps.brown.edu. While we work on a fix, users can continue to access the service via the Microsoft Remote Desktop web client at https://client.wvd.microsoft.com/arm/webclient or the Windows app until this issue is resolved.

For instructions on how to connect to MyApps on Windows, please refer to the OIT help article: https://ithelp.brown.edu/kb/articles/connect-to-myapps-on-windows
Posted Mar 24, 2026 - 11:03 EDT
This incident affected: Other (Other).