Network Outage at Butler Hospital

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 09:03 EDT

Investigating

There is a network outage at Butler Hospital, affecting Wired, Wireless, and VoIP networks. OIT is investigating the incident.
Posted Mar 26, 2026 - 08:25 EDT
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).