OIT Service Alert: MyAccount Passkey Generation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 08:36 EST

Investigating

Due to ongoing maintenance, MyAccount website is unable to send passkeys at this time, please use the email option to generate a passkey. If you need help getting a passkey, please contact the OIT Service Center by phone at 401-863-4357.
Posted Feb 03, 2026 - 20:21 EST
This incident affected: Information Security and Accounts (MyAccount - myaccount.brown.edu).