Power Outage on College Hill Affecting Multiple Brown Services

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 15:32 EDT

Identified

A power outage on College Hill is affecting multiple Brown services, including wired and wireless network in the affected buildings. RI Energy has reported an outage in this area and has posted an ETA of 3:00pm as of the time of this alert.
Posted Mar 09, 2026 - 13:17 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam), Connections on College Hill North of Waterman - Buildings, Connections on College Hill North of Waterman - Outdoor Spaces, Connections on College Hill North of Waterman - Residence Halls).