Wi-Fi Enrollment Service Degradation

Incident Report for Brown University

Update

Brown's Wi-Fi enrollment service, wifi.brown.edu, is degraded, causing long delays in webpage loading. If the page does not load correctly, you can configure yourself for Brown Wi-Fi at our backup page, https://na1.cloudpath.net/enroll/BrownUniversity/Production/process.
Posted Sep 16, 2026 - 10:53 EDT

Investigating

The wifi enrollment service is degraded, causing long delays in webpage loading for wifi.brown.edu. Please try again.

OIT will send updates when more information is available.
Posted Sep 16, 2026 - 10:16 EDT
This incident affects: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam)).