Network Outage: 357 Benefit Street

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 16:34 EDT

Investigating

There is a construction related network outage at 357 Benefit. Wired, wireless, and telephone service are currently down at the location. OIT will update this message when the issue is resolved.
Posted Sep 09, 2026 - 15:20 EDT
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).