MyPrint Degraded for macOS Users

Incident Report for Brown University

Update

Users on macOS are prompted for authentication for every MyPrint print job when running macOS 26.4 or later, 15.7.5 or later, 14.8.5 or later. Selecting the option to "Remember this password in my keychain" does not work. Print jobs are successfully submitted when a user re-enters their Brown username and password for each job. OIT's print vendor has acknowledged the issue, and is working with Apple on a resolution in a future Apple security update.
Posted May 19, 2026 - 10:44 EDT

Identified

Users on macOS are prompted for authentication for every MyPrint print job when running macOS 14.8.5 or later, 15.7.5 or later, and 26.4 or later. Selecting the option to "Remember this password in my keychain" does not work. Print jobs are successfully submitted when a user re-enters their Brown username and password for each job.

We will update this alert with further information when it becomes available.
Posted May 19, 2026 - 10:31 EDT
This incident affects: Desktop and Mobile Computing (MyPrint).