Brown Contract Management (BCM) - Performance Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 14:31 EDT

Investigating

The Brown Contract Management (BCM) system began experiencing performance issues at approximately 11:40 AM EST today, August 19, 2026.

Technical teams are actively engaged and working to identify the root cause and restore service as quickly as possible.

We will provide additional updates as more information becomes available. We apologize for any inconvenience and appreciate your patience while we work to resolve this issue.
Posted Aug 20, 2026 - 14:21 EDT
This incident affected: Administrative and Business (Brown Contract Management System (BCM)).