Extended Maintenance: Partial MyPrint Outage

Incident Report for Brown University

Update

Most devices have been returned to service. We are aware of approximately 20 devices that will need to be manually updated by OIT this morning.
Please contact the OIT Service Center if your printer is not working.
Posted Aug 05, 2026 - 09:04 EDT

Monitoring

This morning's updates to the printing service are taking longer than expected, and as a result, MyPrint may be partly unstable for the moment. OIT is monitoring the situation as the updates complete.
Posted Aug 05, 2026 - 08:20 EDT
This incident affects: Desktop and Mobile Computing (MyPrint).