Power Outage: Haffenreffer

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 15:02 EST

Investigating

There is currently a power outage at Haffenreffer affecting Wired, Wireless, and VoIP connections. RI Energy is communicating with OIT on this matter.
Posted Feb 23, 2026 - 07:17 EST
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).