Some student are experiencing errors when logging into Course@Brown

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 20:32 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2026 - 17:31 EDT

Identified

Some students are experiencing the below error when they log into Courses@Brown:

“Sorry, something went wrong, and we were unable to process your request. Please try again”. Students may see it when they go to their primary cart or search for particular courses. OIT is working with the vendor to fix this issue.

For those students seeing this issue, some of their registrations went through, but they are seeing this error when they try to go back to their cart or search for some other course on the site.

We will update here once we resolve this issue.
Posted Sep 04, 2026 - 17:30 EDT
This incident affected: Teaching and Learning (Course Catalog - cab.brown.edu).